Announcements
Have you sold crypto, shares or property? Our new capital gains tax guide has info about cost bases, calculations & more! Still got questions? Ask the Community!

ATO Community

Re: ATO Business Portal availability

Newbie

Views 805

Replies 3

I am trying to access the Business Portal to input the information and declaration required for the second Jobkeeper payment for May. 

 

The MyGovID link takes me to the Business Portal but it continues to say the system is unavailable due to maintenance. Only scheduled maintenance I can see should have been completed before start of business Monday. Business Portal Systems availability on the ATO website was declared to be available

 

Has the system maintainance gone overtime or is there some other issue I should be aware of?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Most helpful response

Former Community Support

Replies 0

Hello @BigGeoff 

I am not aware of any other issues , If you haven't been able to get your JobKeeper enrolment in due to the scheduled maintenence on the site, no need to worry. You can call us untill 5 June and we can help you get it submitted.

PBlizz

 

3 REPLIES 3

Most helpful response

Former Community Support

Replies 0

Hello @BigGeoff 

I am not aware of any other issues , If you haven't been able to get your JobKeeper enrolment in due to the scheduled maintenence on the site, no need to worry. You can call us untill 5 June and we can help you get it submitted.

PBlizz

 

Former Community Support

Replies 1

Hi @BigGeoff @PBlizz .

 

The ATO Business Portal Dashboard uses real time data sourced from ATO monitoring systems to tell you if the Business Portal is functioning normally or experiencing issues. If you find that the system is showing operational and you are having trouble try clearing your cookies and history. Then log into the Business Portal from our website. Hopefully this will alleviate any issues and you can log in.

 

Thanks,

IssyG

Newbie

Replies 0

Thanks for this, clearing browsing history and cookies worked 🙂