Announcements
We understand that 2020 has been a difficult year but we're here to try and make it a little easier for you during tax time. You can search other people's posts, read our articles or ask your own question.

ATO Community

Error message Sinlge Touch Payroll Lodge

Highlighted

I'm new

Views 1177

Replies 5

Hi all,

My fist lodge (one eployee) went fine. My second lodge (three employees not so good. I have this error message

 

Error: The element in 'Payee"in namespace "http://www.sbr.gov.au/ato/payevntemp"has invalid child element "PersonDemographicDetails"in namespace 'http:/www.sbr.gov.au/ato/payevntemp". List of possible elements expected "PersonNameDetails"in namespace 'http:/www.sbr.gov.au/ato/payevntemp". Hint: while processing parent element [Payee] child mandatory element [PersonNameDetails] was expected but not fpound (code: CMN.ATO.GEN.XML04, location: 1.1=/tnsSmiley TongueAYEVENTEMP/tnsSmiley Tongueayee/tnsSmiley TongueersonNameDetails)

 

I have no idea what this means - can anyone help? I have been back over everything and cannot find an error, I tried to resubmit but now it says

 

Error: We were unable to to process your submission because we already have a submission with this submission ID (code: CMN.ATO.PAYMENT.EM92172, location: 1.0)

 

I take the latter to mean since I tried to submit once I cant try to do it twice.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Best answer

Community Support

Replies 4

Hi @HelenA,

 

We've checked in with a specialist area regarding your query and if you're still experiencing these error messages it's recommended to contact us via the Portal or on 13 28 66 between 8am - 6pm, Monday to Friday to speak with an operator.

 

Thanks, JodieH.

5 REPLIES 5
Highlighted

Best answer

Community Support

Replies 4

Hi @HelenA,

 

We've checked in with a specialist area regarding your query and if you're still experiencing these error messages it's recommended to contact us via the Portal or on 13 28 66 between 8am - 6pm, Monday to Friday to speak with an operator.

 

Thanks, JodieH.

Highlighted

I'm new

Replies 3

Hi Jodei ,

I talk to few different consultants from ATO every time they gave me a differernt solution and non of them worked for me.

I m getting this Error massage "CMN.ATO.PAYEVNT.EM92172" I m not sure what i m doing wrong. 

We only have one entity and i m trying to do an update . why am i getting this .

 

  • The consultants have advise that i havent enter the software provider ID
  • the year to date figures are not alignig
  • the dates are not aligning 

 

I checked all the above options and still couldnt understand where i m going wrong.

 

 

Thank you

 

 

 

Highlighted

ATO Certified

Community Support

Replies 2

Hi @Sherikaperera,

 

I'm sorry to hear that this issue is still ongoing!

 

You've said that you've tried to resolve this a few times, but I just wanted to clarify a few details, if I could.

  • Have you been able to submit any pay events other than this one?
  • If you have been able to submit all other pay events except for this one, are you able to submit an update event or include this information in a subsequent pay event?
  • Have you been able to check your STP reports in the business portal? Do the figures align with what has been submitted (even if an error message was received)?
  • If you haven't been able to submit any other pay events, have you contacted your digital services provider?

This error code "CMN.ATO.PAYEVNT.EM92172" indicates that there is a duplicate payroll event submission ID. What this means for you is that we have probably already received something on our systems. Checking your STP reports in the business portal should show you whether or not we've received the data.

 

If you are trying to submit an original pay event report to make a correction, try submitting it as an update event instead, if your software provider will allow you to. Otherwise, you can also try to update the year to date figures in the next pay event.

 

I hope this is helpful, but please let me know if you have any other questions.

 

Thanks,

 

Rachael B.

Highlighted

I'm new

Replies 1

Hi there, I've been having issues with lodging STP events since Oct 2019 (beginning of Q2 2019). 

Error: The element 'PayrollPeriod' in namespace 'http://www.sbr.gov.au/ato/payevntemp' has invalid child element 'PayrollEventFinall' in namespace 'http://www.sbr.gov.au/ato/payevntemp'. List of possible elements expected: 'StartD' in namespace 'http://www.sbr.gov.au/ato/payevntemp'. Hint: while processing parent element [PayrollPeriod] child mandatory element [StartD] was expected but not found (code: CMN.ATO.GEN.XML04, location: 1.22=/tnsSmiley TongueAYEVNTEMP/tnsSmiley Tongueayee/tns:RemunerationIncomeTaxPayAsYouGoWithholding/tnsSmiley TongueayrollPeriod/tnsSmiley FrustratedtartD)

 

The cycle start date is 27 Sep and end date is 10 Oct 2019 with payment date being 14 Oct 2019. Never had problems in previous cycles. Hope anyone can help. Thank you.

Highlighted

Community Manager

Replies 0

Hi @nikegianti 

 

Looks like one of the following fields hasn't been completed:

  • Business name
  • Business address (note: the ‘Address Line 1’ and ‘Suburb’ fields are compulsory)
  • Business phone number

 

Once these fields have been completed, you should be able to resubmit. If the error continues please contact us.

 

NicolaC